"

MWLite Install on VMWare Guest

Very basic install problem: When I enter the credentials from the Synopsis Confirmation email into the MetaWare Lite Installer, the result is _always_ an alert "Error during Activation. Press OK to re-enter the code or Cancel to Stop Installation.

Host: MacBook Pro (10,1); MacOS 10.12.3
VMWare Fusion 8.5.6
Guest: Windows 10 Professional, all updates through 4/17/2017; only Firefox installed prior to Metaware Lite.

I tried this previously with earlier versions of MacOS and VMWare (not sure which at this point) with the same result.

The end customer is a very large development company; most of their developers use Macs. The problem will be a showstopper for them and scuttle my client's opportunity with them.

Is this a known issue? Is there a workaround?

Comments

  • After aborting the install, I found things were in an advanced state of usability though, unsurprisingly, a project that should build without errors gets an "Invalid Checksum (2)" error. I failed to find a menu item to allow entry of the credentials I tried to enter during the install process.

    Does anybody know if there's a way around this, a menu item I missed or a file that can be edited to make it work?

    TIA - Rick
  • Hi Rick,
    Could you try to install .Net framework(4.5 or later) and use open internet when you activate your account? Here's the applicable .Net download page from microsoft:
    https://www.microsoft.com/en-us/download/details.aspx?id=30653
    This is needed by MWlite. And you could check for supported OS from MWLite installation documents(search for supported OS in the release note). Official MWDT supports widnows 10 while MWLite lags behind in development and there might be some problems.
    Anyway, please let me know after your installation with .Net and how it goes for the activation process. We'll try to help, thanks.
    -Elliot
  • Thanks for the response, Elliot! When I tried to install .NET I got a dialog saying " .NET Framework 4.5 is already a part of this operating system" (screenshot uploaded).

    VMWare gives me three choices for configuring a network adapter. I have chosen the one described this way. 'The virtual machine appears as an additional computer on the physical Ethernet network "Thunderbolt Ethernet Slot 1".' This seems the closest to what you suggested. The other two are "Private to my Mac" ('The virtual machine is connected to your Mac using a private virtual network. The private network is not normally accessible from the physical networks on the Mac.') and "Share with my Mac" (The virtual machine shares the IP address of the Mac on the external network. The Mac provides Network Address Translation for the network traffic from the virtual machine.').

    I'll try the "shared" option, double check the release notes and try Win7 and then post an update on my progress.

    Thanks again.

    Rick
    Screen Shot 2017-04-18 at 19.25.28.png
    540 x 480 - 28K
  • Sure, by "open network" I mean you could access the internet without special restrictions. Some company network denies certain ports, and some blocks some addresses. To make it clear the activation server uses HTTPS protocol and port number 40/443. Hope you could find it helpful. Thanks.
  • Wrap up: Was not able to get this to work on a Win10 guest. Using the same version of VMWare Fusion and the same instance of the MetaWare installer, however, I was able to create a fully functional installation of the MetaWare Lite IDE and Debugger on a Win7 guest.

    It looks like a Synopsys problem in the installer to me.
  • Hi, glad that you could install and use the Lite version. I'm not sure which MWLite you are using but Lite releases are not done on a quarterly basis and it might be lagging behind somehow. You could check the release note after installation and see "supported platform".
    I'm sure win7 is fine. Thanks again.
Sign In or Register to comment.