"

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Error in running/debugging timer_interrupts sample project on embARC201605

I'm trying to run the ide_project (baremetal_arc_feature_timer_interrupt), but I keep getting the following error every time I try opening a debug session and running it:

"target remote localhost:49105
localhost:49105: The system tried to join a drive to a directory on a joined drive.
load
You can't do that when your target is `exec' "

How can I resolve this error.

Thank you.
Capture.JPG
832 x 494 - 77K

Comments

  • Hi,

    There might be two possible causes:
    1. Digilent USB-JTAG driver is not installed.
    2. There are already running instances in the debug session, you need to stop it first, try to find if there is arc-elf32-gdb and openocd processes in system, if yes, kill it first or just do a system reboot.


    If you are using arc gnu 2016.03, you need to follow this link to install the proper driver, which is also documented in embARC documentation: https://github.com/foss-for-synopsys-dwc-arc-processors/arc_gnu_eclipse/wiki/How-to-Use-OpenOCD-on-Windows
    For arc gnu ide, you also need to select right build configuration according to your hardware core.

    I have tried with emsk2.2-arcem7d and emsk1.1-arcem6 in arc gnu 2016.03 in windows7, it works well.



  • I apologize for the late reply. Thank you very much! It worked.
Sign In or Register to comment.